ავტომატური განახლება ვერ ხერხდება WordPress- ზე? FTP ვერ ხერხდება?

WordPressცოტა ხნის წინ, ჩვენ გვყავდა კლიენტი, რომელმაც შექმნა საკუთარი სერვერები WordPress– ზე გამოსაყენებლად. როდესაც ბოლოდროინდელი 3.04 უსაფრთხოება განახლება მოხდა, აქ გარკვეულწილად იგრძნობოდა ამ ვერსიის დაინსტალირება ჩვენს ყველა კლიენტზე. ამასთან, ამ კონკრეტულ კლიენტს ყოველთვის მოსთხოვდა, რომ WordPress ხელით განვაახლოთ… ეს პროცესი არა სუსტი გულისთვისაა!

ჩვენ ვერ მივიღებდით ტიპურ "არ შეუძლია ფაილების წერა”შეცდომა ამ ბლოგზე. ამის ნაცვლად, ჩვენ მოგვცეს ეკრანზე FTP შესვლა. პრობლემა ის იყო, რომ ჩვენ შევავსებდით FTP სერთიფიკატებს და ისიც მაინც ვერ… ამჯერად კარგ რწმუნებათა სიგელების საფუძველზე!

ჩვენს მეგობრებს დაუკავშირდა Lifeline მონაცემთა ცენტრებში, ინდიანაში უდიდესი მონაცემთა ცენტრი, ვინაიდან მათ აქვთ რამდენიმე Apache გეკი და შექმნეს საკუთარი სერვერები. მათ შემოგთავაზეს მარტივი გამოსავალი - FTP სერთიფიკატების დამატება პირდაპირ აქ WP-config.php შეიტანეთ ფაილი, რათა დააკოპიროთ FTP სერთიფიკატები:

განსაზღვრა ('FTP_HOST', 'localhost'); განსაზღვრა ('FTP_USER', 'მომხმარებლის სახელი'); განსაზღვრა ('FTP_PASS', 'პაროლი');

რატომღაც, იდენტური სერთიფიკატები, რომლებიც არ მუშაობდა ფორმაში, მშვენივრად მუშაობდა კონფიგურაციის ფაილში ჩასმისას! ასევე, ეს ქმნის WordPress- ის მოქმედებას, ისევე როგორც FTP the საჭიროების გარეშე. უბრალოდ დააჭირეთ განახლებას და წადით!

4 კომენტარები

  1. 1

    მე განვიცადე WordPress-ის ავტომატური განახლების შეცდომები ჩემი სერვერის აღდგენის და WordPress-ის ახალი ინსტალაციის დაბრუნების შემდეგ. ჩემი პრობლემა წარმოიშვა Firefox-ისგან და არა WordPress-ისგან – სხვებს შეიძლება ჰქონდეთ იგივე პრობლემა, თუ მათი FTP მომხმარებლის სახელი და WordPress მომხმარებლის სახელი იგივეა, რაც ჩემი იყო (თუმცა განსხვავებული კაპიტალიზაციით და პაროლებით).

    პრობლემა ის არის, რომ Firefox, თუ ჩართული გაქვთ „პაროლების დამახსოვრება“, ავტომატურად შეასწორებს მომხმარებელს/გადასვლის ფორმას, რომელიც მისი აზრით უნდა იყოს დაფუძნებული პაროლის მენეჯერში შენახულზე. ჩემს შემთხვევაში, ჩემი WordPress სერთიფიკატები შენახული იყო, მაგრამ ჩემი FTP სერთიფიკატები არ იყო, რადგან მათი გამოყენება შესაძლებელია SSH-ისთვის საიტზე. ამ სიტუაციაში მყოფ ადამიანებს შეუძლიათ ან დროებით გამორთონ „პაროლების დამახსოვრება“ თავიანთ პრეფერენციებში/ოფციებში, როდესაც ცდილობენ გამოიყენონ WordPress-ის ავტომატური განახლება, ან გამოიყენონ კოდის ნაწილი WordPress-ზე ამ ქცევის გამოსასწორებლად.

  2. 2

    დაგ,

    მე მქონდა იგივე პრობლემა Apache-ს სახლის აშენებასთან დაკავშირებით. აღმოჩნდა, რომ ეს იყო არასათანადო ნებართვების და გარკვეული ფაილების და დირექტორიების მფლობელობის შედეგი.

    http://robspencer.net/auto-update-wordpress-without-ftp/

    ზემოთ მოცემულ ბმულზე მოცემულია ინფორმაცია, თუ როგორ უნდა გამოსწორდეს პრობლემა ftp სერთიფიკატების გამოყენების გარეშე. რა თქმა უნდა, მე არ გირჩევთ, რომ მთელი თქვენი მომხმარებლის დირექტორია 775-ზე გადაიტანოთ (და მე არა), მაგრამ ამან მიმიყვანა სწორი მიმართულებით.

    ადამ

  3. 3

    სხვებისთვის, რომლებიც ეძებენ შესაძლო გადაწყვეტილებებს: კიდევ ერთმა ბლოგერმა გადაჭრა მისი ავტომატური განახლების პრობლემები, როგორც ჩანს, აიძულა მისი ჰოსტი გამოეყენებინა php5 და დაამატა შემდეგი მის .httaccess ფაილში:

    AddType x-mapp-php5 .php

  4. 4

    გმადლობთ ცოდნის გაზიარებისთვის, მე მქონდა პრობლემები ავტომატურ განახლებებთან დაკავშირებით, მაგრამ ერთადერთი გამოსავალი, რომელიც ვიპოვე, არის დანამატების გამორთვა, შემდეგ WordPress-ის ავტომატური განახლება და ბოლოს ყველა დანამატის რეაქტიულობა.

    ეს რჩევა არის სხვადასხვა პრობლემისთვის, მაგრამ კარგია იცოდეთ როგორ გადაჭრათ იგი.

    მოგესალმებით მექსიკიდან!

რას ფიქრობთ?

ეს საიტი იყენებს Akismet- ს, რათა შეამციროს სპამი. შეისწავლეთ თქვენი კომენტარის მონაცემები დამუშავებული.